Issues with telephones
Incident Report for B4B Payments
Resolved
Our supplier has resolved the incident affecting our phone service. Please accept our apologies for the service interruption.
Posted Nov 10, 2020 - 08:44 UTC
Update
Our supplier is still working on resolving this issue, but currently we have no estimate for completion. Please accept our apologies for this continued interruption to our phone lines.
Posted Nov 09, 2020 - 18:48 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 17:46 UTC
Investigating
We are currently investigating an issue with our telephone service, which is affecting all inbound calls. We are working with our upstream provider to get a resolution as quickly as possible.
Posted Nov 09, 2020 - 17:46 UTC
This incident affected: Automated phone lines.