Supplier outage
Incident Report for B4B Payments
Resolved
This incident has been resolved
Posted Oct 07, 2019 - 17:14 UTC
Monitoring
A key supplier is currently experiencing system problems which are resulting in intermittent card transaction failures. We are working with them to resolve this as soon as possible. Please accept our apologies for the recurrence of this issue.
Posted Oct 07, 2019 - 17:01 UTC
This incident affected: Card spend transactions.