Website currently under maintenance.
Incident Report for B4B Payments
Resolved
This incident has been resolved.
Posted May 27, 2020 - 13:08 UTC
Investigating
Due to changes on our website its layout is currently insufficiently rendered. Core functionalities like the admin and cardholder portals including logging into them are not affected. By using the following URLs directly accessing the portals is still possible: https://www.b4bpayments.com/login | https://www.b4bpayments.com/login/company_admin_login | https://www.b4bpayments.com/login/institution_admin_login
Posted May 27, 2020 - 12:53 UTC
This incident affected: Website.