Reports not working
Incident Report for B4B Payments
Resolved
This incident has now been resolved. Please accept our apologies for the issue with the reports.
Posted Jun 01, 2020 - 10:46 UTC
Investigating
We are currently experiencing problems generating some reports via our platform. The root cause of this issue has been identified and we are implementing a fix. We hope to have this functionality restored shortly.
Posted Jun 01, 2020 - 08:05 UTC
This incident affected: Reports.