Reports temporarily unavailable
Incident Report for B4B Payments
Resolved
The issue has now been resolved and reports are working normally. Please accept our apologies for this brief interruption.
Posted Jul 01, 2020 - 08:33 UTC
Investigating
We are currently experiencing some problems with our reporting infrastructure. Some reports are currently unavailable. We are working to resolve the issue as quickly as possible. Card functionality is unaffected. We apologise for any inconvenience caused.
Posted Jul 01, 2020 - 08:17 UTC
This incident affected: Reports.