Intermittent merchant spend and ATM withdrawal issues
Incident Report for B4B Payments
Resolved
This incident is now resolved and transactions are flowing normally. Once again, please accept our apologies. We will issue a statement shortly.
Posted Jul 06, 2020 - 09:35 UTC
Update
Following remedial action by Mastercard, the vast majority of transactions are now processing normally. We are continuing to monitor the situation closely. Again, please accept our apologies for this network issue. We are seeking clarification from Mastercard and will provide a statement as soon as we can.
Posted Jul 05, 2020 - 12:58 UTC
Monitoring
We are seeing improvement across the network as the Mastercard continues to work on the issue. If you or your cardholders are experiencing further problems please contact our customer services team. We will continue to monitor the situation.
Posted Jul 03, 2020 - 14:58 UTC
Identified
We understand that Mastercard have identified the cause of the issue and are working to resolve it. We will provide further updates when we have more information. Please accept our apologies for the continuing intermittent disruption.
Posted Jul 03, 2020 - 13:32 UTC
Update
We are continuing to investigate this issue. Both ATM withdrawals and merchant spends are being intermittently affected. Mastercard is continuing to work to resolve this as quickly as possible.
Posted Jul 03, 2020 - 10:19 UTC
Update
We are continuing to investigate this issue.
Posted Jul 03, 2020 - 10:08 UTC
Investigating
We are aware of intermittent problems some cardholders are experiencing with ATM withdrawals and merchant spends. The majority of transactions are unaffected and we are working with Mastercard to identify the cause of this network issue. Please accept our apologies for any inconvenience caused. We will provide more information as we receive it.
Posted Jul 03, 2020 - 09:49 UTC
This incident affected: Card spend transactions.